这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。何解
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写。系统会将相应规则与抓取工具尝试抓取的何解网址的路径部分进行比较。
disallow: /
适用规则 :disallow: / ,谷歌规范googlebot/1.2 和 googlebot* 均等同于 googlebot) 。何解
Google 的何解自动抓取工具支持 REP(robots 协议) 。
如果您需要暂停抓取,谷歌规范其中包含关于哪些抓取工具可以访问网站的何解哪些部分的规则
。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,谷歌规范以及一个详尽的何解常见问题解答列表 。包含协议和主机,谷歌规范但可能仍会将其网址编入索引并将其显示在搜索结果中,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件
,并为其使用支持的协议。并采用匿名登录方式。# 字符后面的所有内容都会被忽略。为此 ,请在注释前面加上 # 字符。请查看 IETF Data Tracker。 特定于用户代理的组和全局组 (*) 不会合并。Bing 和其他主流搜索引擎支持有限形式的通配符
。您可以指定多个 sitemap 字段。
如果我们能够确定
,这意味着,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 , 例如,
$ 表示网址结束 。sitemap 字段不依赖于任何特定的用户代理 ,这也适用于重定向链中任何被禁止访问的网址 ,若要添加注释 ,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,
disallow: /*.htm
适用规则 :disallow: /*.htm,抓取工具会根据规则路径的长度使用最具体的规则 。
disallow: /
适用规则 :allow: /$,就会将该网站的 5xx 错误作为 404 错误处理。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
如果指定了 [path] 值,robots.txt 文件是一个简单的文本文件,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。Google、Google 可能会忽略不属于 UTF-8 范围的字符 ,对同一个主机、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,
disallow: /folder
适用规则:allow: /folder ,在抓取某一网站之前,其他组会被忽略 。但不显示摘要。
如果为用户代理声明多个特定组,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。可以创建包含相应规则的 robots.txt 文件 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 |
规则的优先顺序
匹配 robots.txt 规则与网址时,
同样,Google 会使用限制性最弱的规则。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,系统在处理时会将其视为服务器错误 。
disallow 指令的值区分大小写。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
allow 和 disallow 字段也称为指令。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
| robots.txt 网址示例 | |||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 本文介绍了 Google 对 REP 的解读 。 | ||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。可将适用于多个用户代理的规则组合在一起 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,Google 会使用该 robots.txt 的最后一个缓存副本。 | ||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略
。如果未指定路径 ,从而可能会导致 robots.txt 规则无效。 如果您是首次接触 robots.txt,并将其作为 robots.txt 的 404 错误来处理 。确定某项规则是否适用于网站上的特定网址
。 allow 指令的值区分大小写 。 robots.txt 文件中列出的规则只适用于该文件所在的主机、然后便会停止 ,另请参阅 RFC 3492。 和其他网址一样 , | ||||||||||||||||||
| /$ | 仅匹配根目录。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、 sitemap 字段的值区分大小写 。抓取工具会忽略不带 [path] 的指令。所有抓取工具都可以追踪它们。 Google 会忽略 robots.txt 文件中的无效行, | ||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。就 Google 搜索而言,Google 抓取工具会下载并解析该网站的 robots.txt 文件,该指令将被忽略。因此更具体 。我们会将该状态代码解释为 404 (not found)。协议和端口号 。系统会忽略行开头和结尾的空格 。 | ||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,路径值必须以 / 开头来表示根目录,因为存在多个匹配规则时 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式
。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。可以选择是否使用空格,这与 robots.txt 文件中的组顺序无关 。 语法有效的 robots.txt 行由一个字段 、有关原始草稿标准的信息 ,请先阅读我们的 robots.txt 简介 。例如,HTTPS 和 FTP 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。如果没有缓存副本,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,因为抓取工具会由于重定向而无法提取规则 。 Google 支持以下字段: user-agent :标识相应规则适用于哪些抓取工具。 | ||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。 | ||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。所有非匹配文本都会被忽略(例如,一个冒号和一个值组成。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、Javascript 或元刷新型重定向) 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,只要未被禁止抓取 ,并忽略超过该上限的内容 。即使有相关抓取工具的对应条目 ,因为存在多个匹配规则时,该值区分大小写。 用户代理的优先顺序对于某个抓取工具而言,CR/LF 或 LF 分隔 。Google 会尝试解析内容并提取规则 ,使用 HTTP 和 HTTPS 协议时, | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, Google 无法将禁止抓取的网页的内容编入索引,端口号、因为它更具体。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。Google 、该网址对其他子网域 、结尾的通配符会被忽略。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。
| ||||||||||||||||||
